MININIM next major release

A free software implementation of Prince of Persia 1.
User avatar
Norbert
The Prince of Persia
The Prince of Persia
Posts: 5565
Joined: April 9th, 2009, 10:58 pm

Re: MININIM next major release

Post by Norbert »

oitofelix wrote: September 28th, 2020, 7:24 amPlease, let me know whether it works fine for you.
Yes, that one also works. Three things I noticed: it starts with Macintosh graphics, and I see no menu entry to change graphics (e.g. to DOS), the "Video (F12)" menu entry has no icon and is empty (contains nothing), and after closing the application it says - reproducibly:
Spoiler: show
MININIM: Hope you enjoyed it! :)
The program 'ld-linux-x86-64.so.2' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
(Details: serial 4925 error_code 9 request_code 149 minor_code 2)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
User avatar
atrueprincefanfrom18
Site Shah
Site Shah
Posts: 1776
Joined: January 21st, 2020, 2:53 pm
Contact:

Re: MININIM next major release

Post by atrueprincefanfrom18 »

Yes, even I had Macintosh graphics. Is it not possible to use DOS ones? (Although I liked the Macintosh graphics.)
Love to create new MODS :)

My complete list of mods until now!

My channel. Do consider subscribing it! :)
User avatar
dmitrys
Developer
Developer
Posts: 195
Joined: October 1st, 2020, 6:05 am

Re: MININIM next major release

Post by dmitrys »

I tried to play Minimum and really loved the multi-room view and improvements in sound and guard physics.

However, the Shift button and the time it takes kid to take out the sword seems VERY laggy making it difficult to play. I am not sure if this is just my setup (Windows 10) that causes it.
Zukelik
Efendi
Efendi
Posts: 7
Joined: October 9th, 2021, 7:19 am

Re: MININIM next major release

Post by Zukelik »

Hello. I have tried to build the program, but it seemed to have some problems. If I build the master, it requires Lua 5.0.x, while I have 5.1.5, and if I build the alpha, it wanted 5.3.x. I also have recent LuaJIT however. Is it possible to build with it?

Anyway, I guess this issue is solvable. But it also tries to use some gnulib-tool in bootstrap script, which I don't have, nevertheless the ./configure file is generated after running it. So is gnulib mandatory for building or not?
Post Reply