Incomplete Load: Black Screen after New Game

Moderator: English Moderator Team

CodenameD
Scholar Scribe
Scholar Scribe
Posts: 1
Joined: November 1st, 2011, 7:48 pm

Incomplete Load: Black Screen after New Game

Postby CodenameD » November 1st, 2011, 8:07 pm

I run PoP3D on a Dual-Core processor and Windows XP. And have an integrated graphics card (though the problem happens to be unrelated to graphics). I've patched the game with all the known patches. The game launches fine but after the first FMV sequence the loading bars do not progress all the way to the end and I end up seeing a black screen with the prince falling infinitely downwards with three lifes and the sword icon.

This is the link to the screenshot:

http://i275.photobucket.com/albums/jj29 ... d_prob.jpg

Runs on Win98/ME Mode and processor affinity set to use 1 CPU only. Fails to run without compatibility mode.

What's the problem? How do I fix?

Shattered
Sheikh
Sheikh
Posts: 34
Joined: January 23rd, 2010, 3:19 pm

Re: Incomplete Load: Black Screen after New Game

Postby Shattered » November 6th, 2011, 8:49 pm

First of all: what version do you have of the game? The full 2CD version or a rip?

Not sure if you know this already: the v1.01 patch has a bug; it installs all the files in the Windows directory instead of the game directory. To overcome this problem, do the following:

1. After installing PoP3D, run regedit;
2. Open "HKEY_LOCAL_MACHINE\SOFTWARE\Red Orb\Prince of Persia 3D\1.0";
3. Add a new string value named "Directory", pointing to the directory where the game has been installed in;
4. Install the patch.

This should work on XP, tested it myself.

EDIT:

I've uploaded the unpacked patch here:

viewtopic.php?f=65&t=3092


Return to “Prince of Persia 3D”

Who is online

Users browsing this forum: No registered users and 1 guest