PoP1-Total Pack: New version development

A user-friendly interface for downloading, tweaking and playing mods.

Moderator: English Moderator Team

User avatar
starwindz
Sultan
Sultan
Posts: 133
Joined: March 8th, 2009, 4:48 pm

Re: PoP1-Total Pack: New version development

Post by starwindz » April 11th, 2017, 12:37 am

malvivio wrote:Is it true now we can download also King of Persia and Secrets of the citadel being able to play from Total Pack? Both 3.01 and 3.5??
'King of Persia' can be run on 3.5 but I found that 'Secrets of the citadel' still do not work on 3.5 since SLDPoP is not included in 3.5. It will be fixed in the next version. Thank you.
malvivio wrote:Some bugs still remain also from 3.5 (Prince being cut in chompers after gone throw the door in levels 5 and 8 in New 13 Levels playing it from the start)
If the bugs you mentioned above is about 'New 13 Levels' mod, total pack can not handle it since I am not the author of this mod. Could you please fix it via Roomshaker or Apoplexy? :)
malvivio wrote:I see in 3.5 there are also SNES levelsets but still unable to play them also with Total Pack,
Please check out again. SNES mod can be run via Snes9x emulator.
malvivio wrote:so I guess this is not the final version, it's in the middle; that's why it's named 3.5
Yes. 4.0 will include new random level generator mod named 'Infinite Adventure' being developed now.

salvadorc17
Calif
Calif
Posts: 521
Joined: August 27th, 2011, 2:04 am

Re: PoP1-Total Pack: New version development

Post by salvadorc17 » April 12th, 2017, 9:14 pm

starwindz wrote: Please check out again. SNES mod can be run via Snes9x emulator.
Its working ok for me, just have tested with some mods. Was wondering if youre planning some hex editing for startup in snes mods..

David
The Prince of Persia
The Prince of Persia
Posts: 1474
Joined: December 11th, 2008, 9:48 pm
Location: Hungary

Re: PoP1-Total Pack: New version development

Post by David » April 15th, 2017, 10:23 am

malvivio wrote:(Prince being cut in chompers after gone throw the door in levels 5 and 8 in New 13 Levels playing it from the start)
That's funny: I could reproduce that a few minutes ago on level 8 (maybe even twice?), and then never again.

But, as Starwindz wrote, this is a bug in PoP or the levels, and not in Total Pack itself.

By the way, the super2xsai scaler of DOSBox (the default setting in Total Pack) makes the potions' bubbles hard to see.
When I did the above-mentioned test, I thought that all potions were empty!

malvivio
Efendi
Efendi
Posts: 16
Joined: March 1st, 2017, 10:41 am

Re: PoP1-Total Pack: New version development

Post by malvivio » August 6th, 2017, 10:36 am

I have to segnalate a bug in Total Packs: from some week when I open both 3.01 and 3.5 they tell me: Invalid Enum Value and now that new games have been added, I see they don't appear: my Total Pack 3.01 now has games until 176: The Prince in the illusion; 3.5 until 178: Little time.

Why it doesn't update itself anymore?? :( :cry:

User avatar
Norbert
The Prince of Persia
The Prince of Persia
Posts: 3121
Joined: April 9th, 2009, 10:58 pm
Contact:

Re: PoP1-Total Pack: New version development

Post by Norbert » August 6th, 2017, 11:23 am

malvivio wrote:both 3.01 and 3.5 they tell me: Invalid Enum Value] [...] Why it doesn't update itself anymore?
Hm, I just tested 3.5 and it works for me. I suggest you re-download 3.5.
I will email starwindz a link to your post, maybe he knows why you got the message.

malvivio
Efendi
Efendi
Posts: 16
Joined: March 1st, 2017, 10:41 am

Re: PoP1-Total Pack: New version development

Post by malvivio » August 6th, 2017, 2:45 pm

There's nothing to do Norbert: by redownloading it gets worse: it gaves me games only until 171: Damian0's Levels, I think it was the last game when Total Pack 3.5 have been created. The older games can be played, but it keeps not giving me the newer games. And I don't even know the meaning of "enum"!

David
The Prince of Persia
The Prince of Persia
Posts: 1474
Joined: December 11th, 2008, 9:48 pm
Location: Hungary

Re: PoP1-Total Pack: New version development

Post by David » August 6th, 2017, 4:25 pm

malvivio wrote:Why it doesn't update itself anymore?? :( :cry:
You could try to manually update the mods list.
Download these two files into the mods\levelset\ folder within the Total Pack folder:
https://www.popot.org/xml/mods.xml
https://www.popot.org/xml/modsu.xml
Just overwrite the already existing files of the same name.

Norbert wrote:I will email starwindz a link to your post, maybe he knows why you got the message.
It would be good if starwindz was not the only person who can fix Total Pack bugs...
He should make this open-source, like he did with Infinite Adventure.

Norbert wrote:Hm, I just tested 3.5 and it works for me. I suggest you re-download 3.5.
I have a different problem.
On startup I get this error: "Error downloading URL: http://www.popot.org/xml/modsu.xml"

If I open that URL in Internet Explorer (8), it redirects to the HTTPS version, and it tells me that the certificate of the website is invalid.
For some reason it sees a certificate different from what Firefox sees.
IE sees a certificate for "000000000.nl".

My guess is that Total Pack tries to use the HTTPS capabilities built into Windows (XP), which is quite outdated nowadays.

(Remember, I already mentioned that IE8 just can't open GitHub.com at all.)

If I manually update the mods list (as I wrote above), then when I try to install a mod, I get similar errors again.
Once for the mod itself, and once for the screenshots.

malvivio
Efendi
Efendi
Posts: 16
Joined: March 1st, 2017, 10:41 am

Re: PoP1-Total Pack: New version development

Post by malvivio » August 6th, 2017, 8:58 pm

it seems all very difficult... opening these two link I saw a very long HTML page, and another similar but different in mods>levelset.
It's such a shame it is so!

David
The Prince of Persia
The Prince of Persia
Posts: 1474
Joined: December 11th, 2008, 9:48 pm
Location: Hungary

Re: PoP1-Total Pack: New version development

Post by David » August 12th, 2017, 9:57 am

malvivio wrote:it seems all very difficult... opening these two link I saw a very long HTML page, and another similar but different in mods>levelset.
It's such a shame it is so!
You need to right-click my links, choose "Save target as...", and save the files to the mods\levelset folder.

malvivio
Efendi
Efendi
Posts: 16
Joined: March 1st, 2017, 10:41 am

Re: PoP1-Total Pack: New version development

Post by malvivio » August 12th, 2017, 12:23 pm

David, the first document includes thousands and thousands of rights; most of them hidden in the right or the left of the page! It's not admissable looking the right pieces of copy and glue. I tried doing so, and as result now I have one more problem because all the total pack become EMPTY!

Here there's really need somebody fixes it and makes it work good again.

I made copy and glue of the missing mods, from 176 to 179, in total pack 3.01 and after doing this it still tells me Invalid Enum Value, and then it says also:
End tag 'mods' does not match the start tag 'mod'.
Line: 10946
</mods>ame>.


Now it's absolutely unthinkable going looking for that number line in that long long long extra long document!!

David
The Prince of Persia
The Prince of Persia
Posts: 1474
Joined: December 11th, 2008, 9:48 pm
Location: Hungary

Re: PoP1-Total Pack: New version development

Post by David » August 12th, 2017, 6:47 pm

malvivio wrote:It's not admissable looking the right pieces of copy and glue.
malvivio wrote:I made copy and glue of the missing mods, from 176 to 179,
You don't need to copy and paste.
https://www.popot.org/xml/mods.xml <-- Click this link with the right mouse button, a menu should appear.
From the menu select "Save target as..." (or something similar, depending on which browser are you using), and save the file somewhere.
Now, copy the downloaded file into the mods\levelset\ folder, and overwrite the old file.

malvivio
Efendi
Efendi
Posts: 16
Joined: March 1st, 2017, 10:41 am

Re: PoP1-Total Pack: New version development

Post by malvivio » August 12th, 2017, 9:24 pm

I made as you told: seems it works, doing this 179 has been added into the list of the Total Pack.
Pity it refuses to install it and also the other mods previous not installed in it!!

So it adds new mods in the list but doesn't allow to install them, cause it still says: Invalid Enum Value

DAMN!!

User avatar
Norbert
The Prince of Persia
The Prince of Persia
Posts: 3121
Joined: April 9th, 2009, 10:58 pm
Contact:

Re: PoP1-Total Pack: New version development

Post by Norbert » August 12th, 2017, 10:46 pm

David wrote:It would be good if starwindz was not the only person who can fix Total Pack bugs...
He should make this open-source, [...]
Yes. What's happening now is that we don't know when starwindz will become aware that he needs to take action. Could be a matter of days, could be weeks or longer. Meanwhile I'm also getting emails at PoPOT from people who can no longer use Total Pack. (Even non-English, where the only text I recognize is "Total Pack", so I already know why they emailed before passing their text through a translator.) There's probably something in the XML file that Total Pack isn't processing properly. If I knew what, I could attempt to fix the problem by modifying the XML, but just that error message doesn't provide me with enough information to figure out what to change. The XML still validates, and poplaun still works. If anything would ever happen to starwindz and his closed source software ever stops working again, it could instantly lose most of its value. It'll be interesting to hear from him what caused this problem. Hopefully it'll be fixed soon.

David
The Prince of Persia
The Prince of Persia
Posts: 1474
Joined: December 11th, 2008, 9:48 pm
Location: Hungary

Re: PoP1-Total Pack: New version development

Post by David » August 13th, 2017, 10:29 am

malvivio wrote:So it adds new mods in the list but doesn't allow to install them, cause it still says: Invalid Enum Value
Now, that is some progress.

Malvivio, you can manually install mods this way:
* In Total Pack, select the mod you want to install.
* Click the "Go to popot.org page" button. This should open a new window.
* Download the ZIP file of the mod into the mods\levelset\software\ folder within the Total Pack folder.
* Close Total Pack and open it again.

I know it's annoying, but as Norbert wrote, we can't do anything until Starwindz comes back.

Also, Malvivio, which operating system are you using?
Norbert wrote:There's probably something in the XML file that Total Pack isn't processing properly. If I knew what, I could attempt to fix the problem by modifying the XML, but just that error message doesn't provide me with enough information to figure out what to change.
According to malvivio's last post, when the XML is downloaded manually, the Total Pack lists the new mods, but they can't be installed.
So the XML can be parsed, and something else is the problem.

I suspect that it might be the redirection of HTTP to HTTPS on PoPOT that causes problems.
Norbert, maybe you could try turning that off or something.
Norbert wrote:Meanwhile I'm also getting emails at PoPOT from people who can no longer use Total Pack.
When did you get the first such e-mail?
The date might coincide with something...

Jaffar24
Efendi
Efendi
Posts: 6
Joined: May 13th, 2016, 5:56 pm

Re: PoP1-Total Pack: New version development

Post by Jaffar24 » August 13th, 2017, 10:35 am

I'm getting the same problems. I'll try and do what David has suggested.

Post Reply